Time to Upgrade to WordPress 2.8.1

Discussion in 'Webmaster Forum' started by Ceres, Jul 11, 2009.

  1. Ceres

    Ceres New Member

    A reminder to upgrade your WordPress blogs to WordPress 2.8.1. It fixes a vulnerability which allows unprivileged users to view plugins configuration pages and, with some plugins, to modify plugin options and inject JavaScript code.

    Not all plugins are vulnerable to this problem, however WordPress advises that we upgrade to 2.8.1 to be safe.

    2.8.1 also fixes a number of bugs.
     
  2. Ceres

    Ceres New Member

    That's right, it's time to update your WordPress blogs again. WordPress has released a security patch that fixes an XSS vulnerability:

    Here's the official announcement about WordPress 2.8.2.

    Since the introduction of the automatic upgrade option, I find it's not such a big deal to upgrade so often.
     
  3. pubdomains.in

    pubdomains.in New Member

    @ Ceres I agree - I have been updating my blog without even thinking... love the automatic update option :)
     
  4. Ceres

    Ceres New Member

    Re: Time to Upgrade to WordPress 2.8.3

    Apparently not everything was fixed with 2.8.2. Therefore, 2.8.3 has now been released.

     
  5. Jeff

    Jeff Administrator Staff Member

    Security release :( Happens too frequently...
     
  6. chandan

    chandan New Member

    Time to Upgrade to WordPress 2.8.3 :p
     
  7. freeads

    freeads New Member

    Upgrade 2.8.4 is also released
     
  8. Jeff

    Jeff Administrator Staff Member

    Thanks freeads.
     
  9. skyshipper

    skyshipper New Member

    I have been trying to install wordpress for one blog, but everytime the index screen comes up, tried the guides ,404 error ,
    not able to access the .htaccess files?
     
  10. Jeff

    Jeff Administrator Staff Member

    Are you doing a manual or automatic install?

    Why do you need to access the .htaccess file - are you trying to change the file permissions? Is the .htaccess file not showing via ftp?
     
  11. skyshipper

    skyshipper New Member

    tried both autoinstall and ftp! autoinstall progresses till i am able to write new posts, however on 'view post' option, the index page is displayed. I replaced the index.php file with the one in the wp-admin folder, is there any other file i have to copy to the root folder? as the posts shows 404 error.
     
    Last edited by a moderator: Aug 31, 2009
  12. Jeff

    Jeff Administrator Staff Member

    Weird, I've never seen that error before.

    Why are you replacing the index.php file with the one in the wp-admin folder? There is an index.php file in the root folder that should be used instead.

    If that doesn't clear it up, I'd be inclined to back everything up, delete all your files (not the database) and do a fresh install.
     
  13. skyshipper

    skyshipper New Member

    do you mean just reinstall wordpress 2.8.4 ? i re- autoinstalled it using fantastico, however on going to site i reach the same index page... i think there is a simple solution, but just cannot put a finger on it :mad:
    btw its addon domain (HG) ,if that makes any difference..

    i dont have an index.html on the root , is that a prob?
     
  14. Jeff

    Jeff Administrator Staff Member

    Version 2.8.5 just came out. I think they just like to keep every busy upgrading...
     
  15. freeads

    freeads New Member

    Wordpress 2.9 Released. Time for Upgradation!!
     
  16. freeads

    freeads New Member

    RELEASED: WordPress 3.0.1 July 29, 2010
     

Share This Page